Mulighed for at benytte jeres forum ved hjælp af Fri og Open source software

Jeg har lige set et muligvis spændende opslag et-forslag-til-alternativets-politik-om-atomkraft.

Der er nærmest komisk.
For at se Videoen skal man bruge Adobe Systems Lukkede software “Flash Player”.

jeg vil foreslå i opgraderer til WebM

Med venlig hilsen

1 Like

@123: Videoen er et link til YouTube, der konverteres til en embed-kode via forum-softwaren ([Discourse][1]). YouTube vælger selv hvilken afspiller de vil præsentere for dig, og Discourse er i sig selv fri og åben (https://github.com/discourse/discourse), så der er næsten ikke mere man kan gøre i den retning.
[1]: http://www.discourse.org/

1 Like

Jo, det er der sådan set noget der kan gøres : )

Duckduckgo embedder f.eks youtube i html5, så det kan altså godt lade sig gøre.

2 Likes

Du har ret! Det var dog fantastisk. Det er endda tilsyneladende så nemt som at tilføje querystring’en “html5=1”. Det kræver formentlig at man skriver et plugin til Discourse, som opdager YouTube-links og tvinger parameteren på, men det burde ikke være en overvældende opgave. Dog er den nok lige stor nok under en valgkamp. :slight_smile:

2 Likes

Jeg bookmarker lige tråden og forsøger at minde mig selv om, at det skal gøres snarest muligt. Tak for hintet :smile:

Tak til Huulbæk. Christian er langt fra den eneste der ikke kan/vil se video i lukkede formater som Flash.

Jeg har implementeret understøttelse af html5 video i browseren, og lavet et pull request til forfatteren af modulet. Den detekterer understøttelse på samme måde som Modernizr, så den burde ikke give problemer i ældre browsere, men det har jeg ikke haft mulighed for at teste.

Du kan finde pull request’et på github, hvis du ikke har tålmodighed til at vente på at han selv tester og merger. Håber det kan bruges.

2 Likes

Godt gået @joelving! :wave: :smile: